Replay bug ?

Hey guys ! I love the new feature where you can download and watch replays from your games in the client. I use it all the time, when I make a good play I can rewatch it and be proud of myself. Such a play happened yesterday, as Lee Sin I Q on a minion, dash towards jhin, flash behing him, kick him into my team, it won us the fight. Everyone on my team cheered, even Jhin wrote "Gj" in all chat, which means it must've been good. Me being my self centered egotistical self, I wanted to see the replay, so I could show it to my kids when they're old enough to understand, attach it to my resume... But as I press the replay button, my worst nightmare happened : "This replay file has been corrupted and cannot be launched. Please delete and try downloading the file again." Which I have now done 5 or 6 times, the same error message pops up each time. I tried with the game I played just before that one, works perfectly. TLDR : Replay broken. I want my replay. Please tell me how to resolve this issue Game is from 11/03/2017, final score is 6/9/7 (I know, I know, I'm bad), 173 cs in a 43:10 long game in ranked flex, Le Fireheart is my in game name. In case anyone wanted to try and help. Thanks for reading ! See you on the rift

Seems like no one has joined the conversation yet, be the first to comment below!

Report as:
Offensive Spam Harassment Incorrect Board