Game starts while one is in loading screen

Twice now i experienced a bug, where I would stay in loading screen for a long time and get into a game with 2 mins already passed. The loading screen itself looked completly normal, percantage values changed and ping changed (not like the old ones, where they would get stuck and nothing changed anymore), and it would complete to a 100% and then i would get into a 2:13 min game. Twice in ranked, so it was pretty annoying, both for me and ofc my teammates. I dont even know what is causing this, my internet was both times pretty stable, music videos in background were still playing, but ofc i cant completly rule out a package loss or mini-dc. It would just be cool to actually know that something like this happened, so i have to restart the client or something. Bug Description: - New loading screens (after the change) - Normal loading screen indistinguishable from errorless loading - 60-80 ping display (in my case, pretty stable, nothing unusual) - Long loading time - Not synchronous game entry of all participants, im entering the game 2 mins late Faulty behaviour: - Entry game late, like 2 mins into the game Expected behaviour: - Entry game at 0:00 - OR error message to show a disconnect has occured Impact: - Unfair matches, due to afk for up to 3 mins (otherwise probably remake) - No indication for the affected / dcing player if a error / dc has occured Granted, this is not a reproducable bug, and it happened now twice in like 150 games, after you changed the loading screens. But if you display a relatively stable ping and change loading percantages, i and pretty much every user does trust in these indicators and expects normal loading. Errors can happen and DC's happen too, but at least let me know when this happens ....
Share
Report as:
Offensive Spam Harassment Incorrect Board
Cancel