Client Crashes After Pressing Login Button And Gives Me Bugs Splat Screen

i downloaded 9.14 the moment it got released and everything was working fine and i played all kinds of games ( Normals,Draft,Ranked,TFT ) and nothing was malfunctioning (aside from these random crashes that happen in-game but that is happening since forever i just ignore it) so i think its unlikely to be an error caused by 9.14 .Moreover, yesterday my game was working fine i played normally on any server i wanted on any account i wanted to play on but today whenever i open my client it opens normally and everything appears to be very normal i then entered the password and still no problems but the issue is when u press the login button, about roughly 2 secs after pressing the login button the client just disappears and is replaced by the bug-splat menu and to prove that this problem is from the client and not my internet when i enter a wrong password on purpose it doesn't crash and prompts the normal error message so the bug occurs during the logging in phase and no matter how many times i tried the result is the same i have tried restarting my PC many times , i have tried initiating a full repair , i have tried using the hex-tech repair tool normally then i tried forcing a re-patch ( although i don't think it worked because when i opened the client again it didn't download anything and was on 9.14 so that's questionable , and yes i had the hex-tech repair tool running as administrator) i have checked the boards for this problems but the solved ones are at least 3 years old but didn't stop me from trying so i have deleted the S_OK file , i have done literally everything in the connection troubleshooting guide , and continued to restart a couple of times i also submitted a ticket at riot support about 4 hours ago but they didn't answer until now and i even commented on multiple board discussions of people having the same issue but seems that none of them got response from riot so i decided to make my own thread and wish that riot replies comes up with the fix asap or anyone who managed to solve this issue
Report as:
Offensive Spam Harassment Incorrect Board